Jump to content
Sign in to follow this  
ShootingEgg

Series 2a

    Recommended Posts

    8 minutes ago, ShootingEgg said:

    Although I think that what i have will actually do the job. Tomorrow's homework is read how to and see how i get on.. 

    Before you get too far in, just check the threads will marry up. Let us know how you get on. :good:

    Share this post


    Link to post
    Share on other sites
    45 minutes ago, la bala said:

    Before you get too far in, just check the threads will marry up. Let us know how you get on. :good:

    Wont be rushing it. Might only get to the reading part if threaded differently 

    Share this post


    Link to post
    Share on other sites
    58 minutes ago, la bala said:

    Come on SE, did it fit.

    I ended up out for the day :lol:

    Im going to say it fits to something.  Just don't know if its my 2a yet.. 

    My bad.. 

    Share this post


    Link to post
    Share on other sites
    On 12/11/2018 at 22:50, la bala said:

    This post is going to be longer than Vikings.

    I don't doubt it. 9-5 city working means bot much time to work on the old truck... 

    Share this post


    Link to post
    Share on other sites

    All swapped out!!!!! Took all wheels off and checked, rear drivers needs renewing, leak to the slave there. But all other have been re newed by previous owners, bit odd how they didn't do all four.. Now to sort clutch.... Wooo its coming along.. 

     

    DSC-2031.jpg
    DSC-2032.jpg

    Share this post


    Link to post
    Share on other sites

    Glad it fitted ok SE, only one wheel cylinder to fit and you are there. Hope the bleeding goes well. Keep the pics coming. Is that the heater control cable thats been chopped off.

    Edited by la bala

    Share this post


    Link to post
    Share on other sites
    25 minutes ago, la bala said:

    Glad it fitted ok SE, only one wheel cylinder to fit and you are there. Hope the bleeding goes well. Keep the pics coming. Is that the heater control cable thats been chopped off.

    Its bled and working, just the one rear to renew. The thing that is chopped went to the grill so might be historic for a winch release. But was attached to nothing. So lopped it off.. 

    Had a mate who used to work at a lr specialists with me and he was a god send.

    Share this post


    Link to post
    Share on other sites

    Impressed with the new bit fitted amongst the rest. 👍 I love these threads. Wish I had the time and the skill.  

    Share this post


    Link to post
    Share on other sites
    13 minutes ago, oowee said:

    Impressed with the new bit fitted amongst the rest. 👍 I love these threads. Wish I had the time and the skill.  

    Yeah taking the wing off would of made it so much easier but when the bolts were also painted its not happening.  Haha. 

    Going to roll out the barn tomorrow and bimble round the fields to test brakes. 

    Share this post


    Link to post
    Share on other sites

    Well the brakes worked, l was able to load the back full of fire word and deliver it to a mate about 5 miles away, running really rich at the moment so need to tone that down... But it was good to have it on the road and running.. Even the heater works!!! 

    Share this post


    Link to post
    Share on other sites

    The shooting season unfortunately took over my weekends so the 2a has been sat waiting for me. Not touched since November but on Friday i took her out on the last shoot day, started on the button with no issues, yesterday had a few hours tinkering, sorted out the heater that wasn't spinning. Turns out the fan was bent so stuck and unable to turn. Noticed the manifold to exhaust gasket is gone so need to replace that, clutch still a bit sticky so will investigate that further and need to renew one corners brake shoes and think the cold weather has created a leak on the same corners brake slave. Shoot season over landrover season started... 

    Share this post


    Link to post
    Share on other sites

    Trucks now running sweet, clutch issue was just the flexi hose, replaced and sorted. 

    Brake hub oil leak sorted and brakes adjusted. And fitted new matts in front and loadbay, looking a bit tidier now. 

    DSC-2208.jpg
    DSC-2207.jpg
    IMG-20190215-201145-436.jpg

    Share this post


    Link to post
    Share on other sites

    Ditchman might be happy with me now as i got the degreaser out and gave the engine bay a bit of a clean, ive replaced the heater fan in the cab as the old obe was warped and catching, also i thought the lid was rattling around the tailgate so checked it, found the two rear bolts were loose and no middle bolts or front bolts around the base where it meets the body of the car. All bolts tightened or added so now not rattling there. Unfortunately the chap who helped do the brake master cylinder bent the metal. Mid guard and its actually ripped the inner wing which now has two holes whre the bolts should be to hold it on, si the mud guard is now off, and to be fair it neede replacing. 

    DSC-2217.jpg
    IMG-20190223-WA0002.jpg
    IMG-20190223-162133-913.jpg
    IMG-20190223-162133-915.jpg

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    Sign in to follow this  

    • Recently Browsing   0 members

      No registered users viewing this page.

    ×