Jump to content
Sign in to follow this  
shalfordninja33

AL391 20b Gas Piston

Recommended Posts

I went roost shooting on Saturday afternoon, after a dozen or so shots I had a failure to cycle with the bolt stuck half way between rearward and battery. After I cleared the mag tube of the other two shells I tried some gentle coaxing of the bolt to no avail. I packed up and when I got home pulled the forend off, at which point a piece of metal fell onto the dining table 😳 followed by a second piece as i eased the barrel and push rod forward. Close inspection of the piston revealed two broken ears. Que much panic from me as to how I’d get another one, a quick internet search later revealed its not an uncommon fault on early 391s to the point that the piston was redesigned, they’re held in stock in the Beretta e store and a new one arrived this morning.

Has anyone else had a similar issue with a 391?

ive fitted the new piston and hopefully normal service will resume this weekend. 

75A0D70F-BE74-447F-AFFD-C539CABC7D3C.jpeg

Edited by shalfordninja33

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...