Jump to content
Sign in to follow this  
ph5172

Mechanics help - car moves, revs freely, come off power and turbo kicks in

Recommended Posts

Random one for some help please. 
 

X-Type 2L diesel. 
car moves and drives ok. Accelerates no issues in 1st. 
all other gears it seems to accelerate ok up until the turbo should kick in. At that point it revs freely. Take your foot of the accelerator and the turbo kicks in and car takes off like it would if you use cruise resume. 
 

does this in all gears at all speeds. 
no smoke or anything. 
tried the old pulling off with handbrake on and clutch seems fine. 
 

Mrs had to have a jump start yesterday but I doubt that would have anything to do with it?

 

anyone got any ideas before I book it in. 
 

Thanks. 

Edited by ph5172

Share this post


Link to post
Share on other sites

Thanks very much guys. I think you may sadly be correct. 
 

I fear the cost maybe more than the car value 

Share this post


Link to post
Share on other sites

Unless your description is misleading it doesn’t sound like clutch to me at all.

You accelerate fine in first but then loses drive. If you take your foot off the accelerator it regains drive and the turbo kicks in and propels you forwards?

Maybe a sticky turbo wastegate actuator?

Very confusing symptoms!

 

Share this post


Link to post
Share on other sites
7 minutes ago, ditchman said:

just plucking at straws now....................does it have a varible pitch vane turbo charger ?

I think it does. 
 

I instantly thought the turbo. 
 

I will probably end up dropping it into the local specialist when I have a spare day

Share this post


Link to post
Share on other sites
58 minutes ago, ph5172 said:

I think it does. 
 

I instantly thought the turbo. 
 

I will probably end up dropping it into the local specialist when I have a spare day

it may be the actuator for the turbo......those variable pitch tubos are very efficient.....but sometimes they will fure up carbon...and stick ...or maybe the actuator is leaking..........funnily enough it may be a result of the engine not being worked hard enough ..............

just a thought...dosnt sound like the clutch....you would have lost all drive by now...its got to be boost diaphram/pin......actuator ......turbo related

 

let us know what the outcome is........

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...