Jump to content

Defender wiring quirk.


Recommended Posts

The headlights stopped working on my TD5 110. A quick google said likely dim dip relay. Replaced that but still didn’t work. Google also said could be lighting switch. Replaced that but still no luck. Checked all bulbs and fuses all OK. Eventually gave I and took to Defender specialist. He said he had sen this before and replaced starter motor relay and lights worked. There was never a problem with the starter motor! Weird or what. 
 

Link to post
Share on other sites

Interesting. I had a similar thing with a wiring loom in my Audi, wasted a lot of money and time “fixing” the problem until I gave in and took it to Audi, a couple of hours later and £150 it was perfect. I had probably spent much more than that trying to bodge it. Electronics are not my forte, I understand it all on paper but it’s all too fiddly for my ham fists and I get impatient. 

Link to post
Share on other sites
7 minutes ago, ditchman said:

had the same problem on mine.............it was the stalk unit on the steering column

Which was the second thing I replaced after the dim dip relay behind the instrument panel. Turned out to be expensive as I was ‘persuaded’ to buy some LED headlamps at the same time! 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...