Jump to content

Hatsan not cycling carts


Recommended Posts

Hi all out yesterday with Hatsan semi around 3 years old had issues cycling 28g 7s give it a good clean still having problems checked gas ports some carbon deposits so give them a good clean tryed it yesterday cycled first few shots then shot shell was not coming out of chamber noticed the shells I took out had a small splice off the side near the nose of the shells any help will be much appreciated thanks 

Link to comment
Share on other sites

some times you get bad shells that they rip the metal  i had some years ago keep jamming in an over & under i had turn them so the torn bit was not under the ejector so they could be removed have a look at the metal on the cart.  to see if there is any gap between the metal and case if there is that's the problem

 

Link to comment
Share on other sites

if its running fine with 32g and having failure to eject using 27g  it sounds like theyve just not got enough poke to fully cycle the action. the escort is designed to run carts up to 3" magnum, light clay carts may be a bit anemic for it.  i found mine ran better and all my semi auto gas piston guns for that matter. when completley degreased and lubed up using graphite powder insed of oil.   is it a new gun or is this a new issue its developed?

Edited by Sweet11-87
Link to comment
Share on other sites

Mate had 50 hull superfast  7.5 fibres  through his yesterday as most of em  zinged past my nose on the clay ground he doesn’t shoot owt else at clays !

superfast are punchy so should have no issue afaik in your hatsan so unless you are on a dodgy batch don’t recon it’s the shells

a photo of the broken shell may help.

where are you ? might be worth seeing if anyone local with experience could look it over ? 
 

Btw did it suffer from same problem before the strip down clean ?

Atb

Agriv8

Edited by Agriv8
Link to comment
Share on other sites

No issues before cleaning and yes the o ring is in tackt and where it should be I will get a picture of the shell later after work it’s frustrating as the gun cycled the first 8 shells then started leaving the spent shell in the chamber I will give it ago with the graphite powder but I think I will put it in to be looked at thank you for all your reply’s I will let you know the out come thanks 

Link to comment
Share on other sites

I had issues on my escort with the barrel not seating 100% back into the action on reassembly. It caused all sorts of issues with cartridges not cycling but to the naked eye it looked correctly assembled. Found I have to reassemble the gun with the butt on the floor and put some weight on the barrels to force them back into the action while tightening the screw cap.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...