Jump to content

Land Rover Defender 90, full beam lights not working


agusta
 Share

Recommended Posts

I recently purchased a Land Rover Defender pick up to help clear a few trees we have cut down, went out last night flicked the headlights on, no full beam.

 

Dipped beam works on the switch but full beam doesn't, the only way to get the full beam to work is by using the stork/flasher thingy. So what would you say it is, I would say its the switch, but has anyone else got any ideas?

 

:good:

Link to comment
Share on other sites

i would have thought that the bulb only has one earth-so if it works on dip then the earth must be good?-its either the switch or the relay-any auto electrician will diagnose the problem in a couple of minutes-is it really worth messing around yourself?-or just get bits from a breaker and swap em over. :good:

Link to comment
Share on other sites

dont know much about electrics,but on my freelander,side lights were working,then second click on switch ,main beam,wouldnt work,but flasher and high beam worked ok,checked fuses and relays,and phoned for price on stalk thinking it was that,but thought check bulbs first,and when i moved the spring clip holding bulb in ,it came on,and same happened on other side,working fine now,so worth a check. :good:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...