Jump to content

12g Browning Maxus not firing


Recommended Posts

Hi

This morning my Maxus stopped working! I fed the cartridges in as per normal, closed the bolt, shouldered the gun, squeezed the trigger and just a click.

No strike marks on the cartridges and there were no issues with them as they worked fine in another gun.

I last shot with it prior to lock down and it worked fine, it was stripped and cleaned during lock down and i stripped it again when i got home today and could see nothing amiss.

The hammer hits the firing pin fine (the firing pin looks like new), the pin seems to move, but is very difficult to see properly.

Any ideas what could be wrong, has anyone experienced anything like this?

Also does anyone know how i can test if the firing pin is striking without shooting live cartridges?

 

Link to post
Share on other sites

Mate had this on an escort .

He had changed the o ring on the piston 

And it was ever so slightly thicker than the origional one.this stopped the firing pin fully stricking the primer.

On first inspection .you would think the oring difference wouldnt do this but it did.

The correct oring size confirmed it .as it now works fine and dandy..

 

Edited by Ultrastu
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...